Ergebnis 1 bis 10 von 10
  1. #1
    Stiller Leser
    Registriert seit
    03.06.2018
    Beiträge
    3

    Standard WiFi-Pumpkin Hacker Framework

    Hi!
    Habe vor kurzem diesen Framework unter meinem Kali-Linux OS installiert, leider nicht so recht erfolgreich.

    Github bietet dazu zwei Möglichkeiten an:
    git clone https://github.com/P0cL4bs/WiFi-Pumpkin.git
    und: sudo dpkg -i wifi-pumpkin-0.8.5-all.deb

    Beide waren deshalb nicht erfolgreich, weil etwas wichtiges fehlt.

    Es gelingt mir nicht, in der Version 0.8.5 unter dem Menüpunkt Settings, bei den Activity Monitor settings, alle Alternativen zu erhalten.

    Es fehlt die Alternative "Advanced Mode::Monitor MITM Attack.

    In den diversen YouTube videos zu WiFi-Pumpkin kommt kein Hinweis darauf, wie dies zu bewerkstelligen ist.

    Kann mir da einer weiter helfen?
    Jemand schon Erfahrungen gemacht mit WiFi-Pumpkin?

  2. #2
    W32.FunLove Avatar von Dailox
    Registriert seit
    03.07.2015
    Beiträge
    159

    Standard AW: WiFi-Pumpkin Hacker Framework

    Versuch das mal zu installieren und danach hauste n "sudo apt-get install -f" rein.
    Dann sollte er die Abhängigkeiten suchen und installieren. Falls nicht musst du sie manuell raussuchen und halt installieren.

  3. Folgende Benutzer haben sich für diesen Beitrag bedankt:

    sontyp (04.06.2018)

  4. #3
    0x4d6f64 Avatar von Barny
    Registriert seit
    12.01.2007
    Beiträge
    598

    Standard AW: WiFi-Pumpkin Hacker Framework

    Habe mit diesem Framework bisher nichts zu tun gehabt, aber du redest ja jetzt gerade von fehlenden Menüpunkten, ist das richtig?
    Gab es nachdem du das Paket mittels dpkg installiert hast irgendwelche Abhängigkeitsprobleme oder andere Fehler?

    Gruß,

    Barny

    ~~~ Blog ~~~
    ~~~ PGP-Key ~~~

  5. #4
    Black Python Avatar von cruzz
    Registriert seit
    29.01.2016
    Beiträge
    235

    Standard AW: WiFi-Pumpkin Hacker Framework

    Guck mal in die https://github.com/P0cL4bs/WiFi-Pump...quirements.txt
    ... Kannst mit pip alles installieren.
    Einfach: pip -r requirements.txt
    Oder: pip3 -r requirements.txt

  6. #5
    RockSt★r Avatar von Alucart
    Registriert seit
    03.07.2009
    Beiträge
    424

    Standard AW: WiFi-Pumpkin Hacker Framework

    Du möchtest dir bestimmt ein Ewil-Twin bauen mit dem Pumpkin Framework richtig?
    Das funktioniert leider nicht mehr, da es damals eine Sicherheitslücke war, dass sich Smartphones usw. mit einem gleichen AP verbunden haben die plötzlich aber eine offene Autorisierung haben.
    Kann dir Airgeddon empfehlen. Hat die gleichen Funtkionen wie Pumpkin, ist aber dafür ausgelegt die Passwörter als Evil-Twin zu finden.

    if (sad() == true)
    {
    Sad().Stop();
    beAwesome();
    }


  7. #6
    Stiller Leser
    Registriert seit
    03.06.2018
    Beiträge
    3

    Standard AW: WiFi-Pumpkin Hacker Framework





    Zitat Zitat von Dailox Beitrag anzeigen
    Versuch das mal zu installieren und danach hauste n "sudo apt-get install -f" rein.
    Dann sollte er die Abhängigkeiten suchen und installieren. Falls nicht musst du sie manuell raussuchen und halt installieren.
    Danke, werd ich versuchen.
    Ergebnis teile ich dir dann mit.


    ---------- Post added at 14:54 ---------- Previous post was at 14:54 ----------

    Zitat Zitat von Barny Beitrag anzeigen
    Habe mit diesem Framework bisher nichts zu tun gehabt, aber du redest ja jetzt gerade von fehlenden Menüpunkten, ist das richtig?
    Gab es nachdem du das Paket mittels dpkg installiert hast irgendwelche Abhängigkeitsprobleme oder andere Fehler?

    Gruß,

    Barny
    Hier die Fehlermeldung:
    You do not have a working installation of the service_identity module:
    'cannot import name opentype'.
    Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.
    Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification.
    Many valid certificate/hostname mappings may be rejected.

    Habe ich dann korrigiert - leider bleibt die Fehlermeldung!


    ---------- Post added at 14:55 ---------- Previous post was at 14:54 ----------

    Zitat Zitat von cruzz Beitrag anzeigen
    Guck mal in die https://github.com/P0cL4bs/WiFi-Pump...quirements.txt
    ... Kannst mit pip alles installieren.
    Einfach: pip -r requirements.txt
    Oder: pip3 -r requirements.txt
    Werd ich machen. Danke für den Tipp.


    ---------- Post added at 15:03 ---------- Previous post was at 14:55 ----------

    Zitat Zitat von Alucart Beitrag anzeigen
    Du möchtest dir bestimmt ein Ewil-Twin bauen mit dem Pumpkin Framework richtig?
    Das funktioniert leider nicht mehr, da es damals eine Sicherheitslücke war, dass sich Smartphones usw. mit einem gleichen AP verbunden haben die plötzlich aber eine offene Autorisierung haben.
    Kann dir Airgeddon empfehlen. Hat die gleichen Funtkionen wie Pumpkin, ist aber dafür ausgelegt die Passwörter als Evil-Twin zu finden.
    Ja, mit dem Fake AP hast du recht.
    Aber das ist schwer zu glauben, das dieses Framework nicht mehr dafür taugen soll.
    Bei YouTube wird es in der aktuellen 0.8.5 Version erfolgreich vorgeführt.
    Woher ist deine Info? Läßt sich das nachlesen? Eigene Erfahrung?

  8. #7
    Black Python Avatar von cruzz
    Registriert seit
    29.01.2016
    Beiträge
    235

    Standard AW: WiFi-Pumpkin Hacker Framework

    Da war nie eine Lücke... Das basiert auf Social-Engineering.

  9. #8
    RockSt★r Avatar von Alucart
    Registriert seit
    03.07.2009
    Beiträge
    424

    Standard AW: WiFi-Pumpkin Hacker Framework

    Da war wohl mal eine Lücke.
    Früher konnte man einfach einen Evil-Twin erstellen der den gleichen Namen hatte wie dein Router Zuhause.
    Wenn mein Evil-Twin dann ein stärkeres Signal hatte, haben sich all deine Geräte mit meinem Evil-Twin verbunden.
    Das funktioniert heute aber nicht mehr. Die Geräte wissen heute, dass das WLAN ein Passwort hatte und wartet auf diese Abfrage bevor es sich verbindet und Connectet nicht mehr mit offenen AP's mit selben namen. Darauf beruht allerdings noch das Pumpkin-Framework.

    if (sad() == true)
    {
    Sad().Stop();
    beAwesome();
    }


  10. #9
    Trojaner Avatar von Irhabi
    Registriert seit
    06.04.2015
    Beiträge
    58

    Standard AW: WiFi-Pumpkin Hacker Framework

    Etwas off topic, aber ich gebe dennoch meinen Senf dazu:

    ich habe damals auch versucht, Wifi Pumpkin zum Laufen zu bringen, vergeblich. Irgendwann habe ichs dann aufgegeben und wie ich sehe, haben die bis heute das nicht gefixt, lol. Wenn du es nur verwenden möchtest, um Evil Twin Hotspots zu erstellen, dann brauchst du dafür nicht unbedingt ein Programm. Air-Crack kann das beispielsweise auch. Es muss nicht alles klicki-bunti sein, wenn du verstehst was ich meine


    Zitat Zitat von Alucart Beitrag anzeigen
    Da war wohl mal eine Lücke.
    Das funktioniert heute aber nicht mehr. Die Geräte wissen heute, dass das WLAN ein Passwort hatte und wartet auf diese Abfrage bevor es sich verbindet und Connectet nicht mehr mit offenen AP's mit selben namen. Darauf beruht allerdings noch das Pumpkin-Framework.
    Interessant, wusste ich gar nicht, dass es anscheinend nciht mehr funzt.

    Lg,
    Irhabi

  11. #10
    Trojaner Avatar von sontyp
    Registriert seit
    16.09.2016
    Beiträge
    54

    Standard AW: WiFi-Pumpkin Hacker Framework

    Mit Air-Crack lassen sich Evil Twins erstellen? Hab Air-Crack bisher im Sinne eines "Mitlesers" genutzt.

    #define true (rand() > 10) //Happy debugging, suckers!



Ähnliche Themen

  1. WiFi Hack AIO
    Von roccihrs im Forum Wireless-Lan
    Antworten: 0
    Letzter Beitrag: 30.05.2009, 17:51
  2. wifi hack
    Von macbek im Forum Suche Tutorials
    Antworten: 2
    Letzter Beitrag: 26.05.2009, 21:56
  3. wifi
    Von macbek im Forum Anwendungssoftware
    Antworten: 0
    Letzter Beitrag: 26.05.2009, 14:28

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •